[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v6 1/3] arm: rename BIT_{WORD/MASK/PER_WORD) to BITOP_*

On 19/02/2020 11:41, Roger Pau Monné wrote:
On Wed, Feb 19, 2020 at 11:35:16AM +0000, Julien Grall wrote:
Hi Roger,

On 19/02/2020 10:22, Roger Pau Monne wrote:
So BIT_WORD can be imported from Linux. The difference between current
Linux implementation of BIT_WORD is that the size of the word unit is
a long integer, while the Xen one is hardcoded to 32 bits.

Current users of BITOP_WORD on Arm (which considers a word a long
integer) are switched to use the generic BIT_WORD which also operates
on long integers.

No functional change intended.

Suggested-by: Julien Grall <julien@xxxxxxx>
Suggested-by: Jan Beulich <jbeulich@xxxxxxxx>
Signed-off-by: Roger Pau Monné <roger.pau@xxxxxxxxxx>

Acked-by: Julien Grall <julien@xxxxxxx>

Did you build test it on Arm?

Did a gitlab run, build was fine:
 > https://gitlab.com/xen-project/people/royger/xen/pipelines/118878544

Thank you!


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.