[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen fails to resume on AMD Fam15h (and Fam17h?) because of CPUID mismatch

February 10, 2020 12:14 PM, "Marek Marczykowski-Górecki" 
<marmarek@xxxxxxxxxxxxxxxxxxxxxx> wrote:

> On Mon, Feb 10, 2020 at 11:17:34AM +0000, Andrew Cooper wrote:
>> On 10/02/2020 08:55, Jan Beulich wrote:
>> On 10.02.2020 00:06, Marek Marczykowski-Górecki wrote:
>> Hi,
>> Multiple Qubes users have reported issues with resuming from S3 on AMD
>> systems (Ryzen 2500U, Ryzen Pro 3700U, maybe more). The error message
>> is:
>> (XEN) CPU0: cap[ 1] is 7ed8320b (expected f6d8320b)
>> If I read it right, this is:
>> - OSXSAVE: 0 -> 1
>> - HYPERVISOR: 1 -> 0
>> Commenting out the panic on a failed recheck_cpu_features() in power.c
>> makes the system work after resume, reportedly stable. But that doesn't
>> sounds like a good idea generally.
>> Is this difference a Xen fault (some missing MSR / other register
>> restore on resume)? Or BIOS vendor / AMD, that could be worked around in
>> Xen?
>> The transition of the HYPERVISOR bit is definitely a Xen issue,
>> with Andrew having sent a patch already (iirc).
>> https://lore.kernel.org/xen-devel/20200127202121.2961-1-andrew.cooper3@xxxxxxxxxx
>> Code is correct.  Commit message needs rework, including in light of
>> this discovery.  (I may eventually split it into two patches.)
> Claudia, do you want to test with this patch?

I'm getting hunk failed in domctl.c applying to R4.1 default repo (fc31, Xen 
4.13). I'll see if I can fix it but bear with me, I'm new at this.

Marek: Would you by any chance be willing to merge this into a test branch on 
your repo, so the rest of us can pull it directly into qubes-builder? It'll 
take you a fraction of the time it'll take me, plus then zachm and awokd and 
anyone else can pull it also.

Jan Beulich: Yes, based on symptoms this appears to only affect AMD from what 
I've seen so far, although I'm not sure if any Intel users have tried the 
workaround patch. In my case, I experience the exact same symptoms on 4.8, 
4.12, and 4.13, and patching 4.8 resulted in successful resume and confirmed 
the cause of the issue, but I haven't tried patching any other versions. 

Thank you everyone for your attention to this issue so far. This is all over my 
head but I'm happy to provide any additional information I can. I have the 
Ryzen 2500U.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.