[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2] IOMMU: make DMA containment of quarantined devices optional

On 13.12.2019 14:29, Durrant, Paul wrote:
>> From: Jan Beulich <jbeulich@xxxxxxxx>
>> Sent: 13 December 2019 13:26
>> On 13.12.2019 14:12, Durrant, Paul wrote:
>>>> From: Xen-devel <xen-devel-bounces@xxxxxxxxxxxxxxxxxxxx> On Behalf Of Jan
>>>> Beulich
>>>> Sent: 13 December 2019 12:53
>>>> +#define IOMMU_quarantine_none  0
>>>> +#define IOMMU_quarantine_basic 1
>>>> +#define IOMMU_quarantine_full  2
>>>> +uint8_t __read_mostly iommu_quarantine = IOMMU_quarantine_basic;
>>> If we have 'IOMMU_quarantine_sink' instead of 'IOMMU_quarantine_full',
>>> then how about 'IOMMU_quarantine_write_fault' instead of
>>> 'IOMMU_quarantine_basic'?
>> Why "write_fault"? Even in "full" mode you only avoid read faults
>> aiui (see also above). So if anything "write_fault" would be a
>> replacement for "full"; "basic" could be replaced by just "fault"
>> then.
> Sorry, yes, I had things the wrong way round. "fault" and "write_fault" sound 
> good.

But the resulting command line option (iommu=quarantine=write-fault)
would then be quite a bit less nice imo, compare to the brief "full".
(I'm tempted to suggest "nrf" for "no read fault", but I guess that's
too ugly an acronym.)


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.