[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] cmdline: treat hyphens and underscores the same

Hi Jan,

On 06/12/2019 16:42, Jan Beulich wrote:
On 06.12.2019 17:20, Julien Grall wrote:

On 06/12/2019 16:06, Jan Beulich wrote:
On 06.12.2019 15:46, Julien Grall wrote:
On 05/12/2019 16:50, Jan Beulich wrote:
On 05.12.2019 17:27, Julien Grall wrote:
On 05/12/2019 15:33, Jan Beulich wrote:
Anyway, how about calling it cmdline_strncmp()? This would be easier to
spot misuse on review (i.e using strncmp() rather than _strncmp()).

We already have cmdline_strcmp(), or else I would indeed have used
this prefix. No prefix (other than the lone underscore) seemed the
next best option.

As we parse an option, how about opt_strncmp()?

I'd still like _strncmp() better here.

Adding an _ in front of the name does not make very obvious the differences with the non-underscore very.

This should really be limited to things that cannot be named otherwise. In this particular case, there are other possible name a bit longer but more descriptive.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.