[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v8 6/8] docs: documentation about static shared memory regions

On Wed, 31 Oct 2018, Ian Jackson wrote:
> Julien Grall writes ("Re: [PATCH v8 6/8] docs: documentation about static 
> shared memory regions"):
> > On 10/30/18 6:58 PM, Stefano Stabellini wrote:
> > > I completely agree with you here, and getting rid of the master/slave
> > > terminology would be nice, in retrospect, it was not a good choice. But
> > > this is v8 of the series, and as discussed a few times, we encourage
> > > reviewers to avoid this kind of requests at this stage.
> Sorry I'm late to the party.
> > While I agree that the design document has been accepted in Aug 2017,
> > the last things we want is adding more potentially offensive naming in 
> > Xen. It should not take too much to do the renaming (I am happy to help 
> > here).
> Thanks for your support.  I am also happy to help.  I don't mind
> whether this is done by the equivalent of filter-branch on the patch
> series, or with a followup patch to rename everything.  I can
> construct the followup patch if that would be welcome.
> But we need to know what the new terminology should be.  Is `owner'
> and `borrower' a good pairing ?  `Borrow' is perhaps not quite right
> because it implies that the original owner no longer has it while it's
> borrowed.  OTOH Rust has read-only borrows which work similarly so
> borrowing in a way that doesn't exclude the original has at least some
> precedent...
> I see that the Linux DT document doesn't need to mention the role, so
> we just need to fix the Xen tree.

Other options I could think of:

proprietor / renter
benefactor / dependent

But I think owner/borrower is the best choice -- also considering that
"own" and "borrow" are taught in very basic English classes, anybody
should understand them well.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.