[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 4/8] viridian: remove duplicate union types

On Mon, Oct 29, 2018 at 06:02:07PM +0000, Paul Durrant wrote:
> The 'viridian_vp_assist', 'viridian_hypercall_gpa' and
> 'viridian_reference_tsc' union types are identical in layout. The layout
> is also common throughout the specification [1].
> This patch declares a common 'viridian_page_msr' type and converts the rest
> of the code to use that type for both the hypercall and VP assist pages.

I agree with the unification of the viridian_page_msr struct.

> Also, rename 'viridian_guest_os_id' to 'viridian_guest_os_id_msr' since it
> also is a union representing an MSR value.
                               ^ a

IMO (and I'm not that familiar with the code) adding those _msr
prefixes here doesn't seem to add any value to the code, there's
nothing MSR specific in those structs, apart from their size.

Is there a plan to add a new structure like viridian_page_mmio or
similar that requires such prefixes to be present?

Thanks, Roger.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.