[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v4 11/23] xen/arm: refactor construct_dom0


On 05/10/2018 19:47, Stefano Stabellini wrote:
Move generic initializations out of construct_dom0 so that they can be

Rename prepare_dtb to prepare_dtb_hwdom to avoid confusion.

No functional changes in this patch.

Signed-off-by: Stefano Stabellini <stefanos@xxxxxxxxxx>

Changes in v4:
- newline and style changes

Changes in v3:
- move setting type before allocate_memory
- add ifdef around it and a comment

Changes in v2:
- move discard_initial_modules() after __construct_domain()
- remove useless blank line
- leave safety BUG_ONs in __construct_domain
- rename prepare_dtb to prepare_dtb_hwdom
  xen/arch/arm/domain_build.c | 126 ++++++++++++++++++++++++--------------------
  1 file changed, 68 insertions(+), 58 deletions(-)

diff --git a/xen/arch/arm/domain_build.c b/xen/arch/arm/domain_build.c
index fddfd82..ba3dad1 100644
--- a/xen/arch/arm/domain_build.c
+++ b/xen/arch/arm/domain_build.c
@@ -1456,7 +1456,7 @@ static int __init handle_node(struct domain *d, struct 
kernel_info *kinfo,
      return res;
-static int __init prepare_dtb(struct domain *d, struct kernel_info *kinfo)
+static int __init prepare_dtb_hwdom(struct domain *d, struct kernel_info 
      const p2m_type_t default_p2mt = p2m_mmio_direct_c;
      const void *fdt;
@@ -2191,75 +2191,29 @@ static void __init find_gnttab_region(struct domain *d,
             kinfo->gnttab_start, kinfo->gnttab_start + kinfo->gnttab_size);
-int __init construct_dom0(struct domain *d)
+static int __init __construct_domain(struct domain *d, struct kernel_info 

Why do you need to add __ in front? The more we are trying to avoid introducing name/variable with __ in front.

The rest of the patch looks good to me.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.