[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2] amd-iommu: use correct constants in amd_iommu_get_next_table_from_pte()...

On Wed, Sep 26, 2018 at 02:44:07PM +0100, Paul Durrant wrote:
> ...and change the name to amd_iommu_get_address_from_pte() since the
> address read is not necessarily the address of a next level page table.
> (If the 'next level' field is not 1 - 6 then the address is a page
> address).
> The constants in use prior to this patch relate to device table entries
> rather than page table entries. Although they do have the same value, it
> makes the code confusing to read.
> This patch also changes the PDE/PTE pointer argument to void *, and
> removes any u32/uint32_t casts in the call sites. Unnecessary casts
> surrounding call sites are also removed.
> No functional change.
> NOTE: The patch also adds emacs boilerplate to iommu_map.c
> Signed-off-by: Paul Durrant <paul.durrant@xxxxxxxxxx>

Not thrilled about adding the emacs part but it's allowed in the coding
style guide so.

Reviewd-by: Brian Woods <brian.woods@xxxxxxx>

Brian Woods

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.