[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v12 5/9] memory: add check_get_page_from_gfn() as a wrapper...

Hi Paul,

On 09/27/2018 03:33 PM, Paul Durrant wrote:
...for some uses of get_page_from_gfn().

There are many occurrences of the following pattern in the code:

     q = <readonly look-up> ? P2M_ALLOC : P2M_UNSHARE;
     page = get_page_from_gfn(d, gfn, &p2mt, q);

     if ( p2m_is_paging(p2mt) )
         if ( page )

         p2m_mem_paging_populate(d, gfn);
         return <-EAGAIN or equivalent>;

     if ( (q & P2M_UNSHARE) && p2m_is_shared(p2mt) )
         if ( page )

         return <-EAGAIN or equivalent>;

     if ( !page )
         return <-EINVAL or equivalent>;

There are some small differences between the exact way the occurrences
are coded but the desired semantic is the same.

This patch introduces a new common implementation of this code in
check_get_page_from_gfn() and then converts the various open-coded patterns
into calls to this new function.

Signed-off-by: Paul Durrant <paul.durrant@xxxxxxxxxx>
Reviewed-by: Roger Pau Monne <roger.pau@xxxxxxxxxx>
Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>
Cc: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>
Cc: George Dunlap <George.Dunlap@xxxxxxxxxxxxx>
Cc: Ian Jackson <ian.jackson@xxxxxxxxxxxxx>
Cc: Julien Grall <julien.grall@xxxxxxx>
Cc: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Cc: Stefano Stabellini <sstabellini@xxxxxxxxxx>
Cc: Tim Deegan <tim@xxxxxxx>
Cc: Wei Liu <wei.liu2@xxxxxxxxxx>

  - Forward declare p2m_type_t in p2m-common.h to allow the duplicate
    declarations of check_get_page_from_gfn() to be removed, and hence add
    Jan's R-b.

I think this would be worth adding a word in the commit message about the forward declaration.

For the Arm bits:

Acked-by: Julien Grall <julien.grall@xxxxxxx>


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.