[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 0/2] xen/xsm: Cleanup in preparation for XSM SILO mode

>>> On 26.06.18 at 14:42, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 26/06/18 13:04, Jan Beulich wrote:
>>>>> On 26.06.18 at 13:09, <andrew.cooper3@xxxxxxxxxx> wrote:
>>> Future changes will introduce a new SILO mode, which is intended to be 
>>> useful
>>> for cloud and enterprise setups where all domUs are unprivileged and have no
>>> buisness communicating directly.
>>> This was discussed at XenSummit, but I'll leave further details to the 
>>> series
>>> which introduces it.  However, to begin with, clean up the XSM namespacing 
>>> to
>>> better separate XSM and FLASK.
>>> No functional change.
>>> Andrew Cooper (2):
>>>   xen/xsm: Rename CONFIG_FLASK_* to CONFIG_XSM_FLASK_*
>> I don't particularly mind the change, but I also don't view it as
>> particularly useful: For the first patch I'd see the point if you
>> meant to introduce some CONFIG_ABC_FLASK, but that's not how
>> I understand the description there. For the second I don't see
>> the point of retaining XSM in the name.
> XSM != Flask, and this is the naming confusion trying to be rectified.

But why is FLASK alone not meaningful enough?

> CONFIG_XSM_SILO is going to be the introduced new mode.

And then SILO alone here?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.