[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Naming things (was XEN_SYSCTL_get_cpuid_policy)

>>> On 27.02.18 at 18:27, <andrew.cooper3@xxxxxxxxxx> wrote:
> Having finally got back to some CPUID work, I've come back to a naming
> problem I've been unable to resolve in the intervening time.
> Originally, the plan was to introduce XEN_SYSCTL_get_cpuid_policy and
> XEN_DOMCTL_{get,set}_cpuid_policy, which was shortly followed by similar
> MSR policy calls.
> However, to do the hypervisor side audit, the domain set cpuid and msr
> policy calls have to be done together, so all state can be cross-checked
> together.
> Therefore, I was thinking of something more along the lines of
> XEN_DOMCTL_{get,set}_arch_config to be rather more generic, and prevent
> the need to add a new get/set hypercall pair for each class of
> information.  However, that name is confusing with struct
> xen_arch_domainconfig arch_config as part of the createdomain call.
> So, XEN_DOMCTL_{get,set}_arch_settings ?

Taking it that even on the MSR side this is about feature visibility
(rather than actual state), XEN_DOMCTL_{get,set}_feature_policy
or XEN_DOMCTL_{get,set}_capabilities (in both cases perhaps
with "cpu" inserted somewhere for further clarification)?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.