[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Issue with booting with xen,passthrough DTB


I am trying to passthrough the I2C bus[channel 2 group A] to DomU in
Xen. I am implementing this on R-Car H3.

I added xen,passthrough = "1" to the i2c2 node in r8a7795.dtsi and
rebuilt the dtb for Domain 0. The dtb works when I boot into Dom0, but
the kernel crashes when I try to boot again using the same dtb.
Assuming that the integrated device using i2c2 somehow gets corrupted
for the second run, I tried to passthrough the entire rcar sound
system, which is associated with i2c2. But I get the same result i.e.
Kernel boots for the first run but fails when I reboot using the same

Following is the modification in Dom 0 dtb :

i2c2: i2c@e6510000 {
#address-cells = <1>;
#size-cells = <0>;
compatible = "renesas,i2c-r8a7795";
reg = <0 0xe6510000 0 0x40>;
interrupts = <GIC_SPI 286 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&cpg CPG_MOD 929>;
power-domains = <&sysc R8A7795_PD_ALWAYS_ON>;
dmas = <&dmac1 0x95>, <&dmac1 0x94>;
dma-names = "tx", "rx";
i2c-scl-internal-delay-ns = <6>;
status = "disabled";
xen,passthrough = "1";

rcar_sound: sound@ec500000 {
power-domains = <&sysc R8A7795_PD_ALWAYS_ON>;
status = "disabled";
xen,passthrough = "1";
Please see the attachment for the kernel log.

Any support or suggestion regarding the cause of this issue will be
much appreciated.

I have also posted another issue regarding passthrough [1]. Please
have a look into it also.


[1] https://lists.xenproject.org/archives/html/xen-devel/2018-01/msg02618.html

Attachment: log_boot_xen_30012018.txt
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.