[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v3] hvm: vmx/svm_cpu_up_prepare should be called only once



>>> On 18.08.17 at 20:51, <boris.ostrovsky@xxxxxxxxxx> wrote:
> --- a/xen/include/asm-x86/hvm/hvm.h
> +++ b/xen/include/asm-x86/hvm/hvm.h
> @@ -158,7 +158,7 @@ struct hvm_function_table {
>      int  (*cpu_up_prepare)(unsigned int cpu);
>      void (*cpu_dead)(unsigned int cpu);
>  
> -    int  (*cpu_up)(void);
> +    int  (*cpu_up)(bool bsp);

I can see why you want to introduce the parameter here, but it
feels wrong to do so, as ...

> @@ -443,7 +443,7 @@ void hvm_set_rdtsc_exiting(struct domain *d, bool_t 
> enable);
>  
>  static inline int hvm_cpu_up(void)
>  {
> -    return (hvm_funcs.cpu_up ? hvm_funcs.cpu_up() : 0);
> +    return (hvm_funcs.cpu_up ? hvm_funcs.cpu_up(false) : 0);

... you don't need it at this layer - you only ever pass "false".
The previous solution on the SVM side (using a thin wrapper)
seems to me to be the cleaner variant, even if slightly less
efficient (but performance really doesn't matter here).

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
https://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.