[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v3 1/3] x86/ioreq server(patch for 4.7): Rename p2m_mmio_write_dm to p2m_ioreq_server.

> -----Original Message-----
> >
> > For clarity, do you expect any existing use of HVMMEM_mmio_write_dm
> to continue to *function*? I agree that things should continue to build, but 
> if
> they don't need to function then the now redundant p2m type should be
> removed IMO and any attempt to set a page to HVMMEM_mmio_write_dm
> (or the new HVMMEM_unused) name should result in -EINVAL. What is your
> position on this?
> >
> Thanks, Paul.
> My expectation is that HVMMEM_mmio_write_dm shall fail in new xen
> version, but I do not think we need to remove the p2m type, just
> rename it could be OK.

I think we need George's response before we can proceed.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.