[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Question about the CAT and CMT in Xen

On 31/08/15 21:09, Meng Xu wrote:
> Hi Andrew and Chao,
> 2015-08-31 14:25 GMT-04:00 Andrew Cooper <andrew.cooper3@xxxxxxxxxx>:
>> On 31/08/15 18:42, Meng Xu wrote:
>> Hi Chao,
>> I'm Meng Xu from the University of Pennsylvania.
>> We purchased a computer that has Intel(R) Xeon(R) CPU E5-2618L v3 @ 2.30GHz 
>> inside.
>> According to 
>> http://www.intel.com/content/www/us/en/communications/cache-monitoring-cache-allocation-technologies.html,
>>  Intel E5-2618L v3 should support both CAT and CMT.
>> I'm playing the latest Xen on the machine to evaluate how CAT and CMT work
>> .
>> The commit point I used is in the staging branch, commit 
>> 7b99717f62caeac08eea224a177cd28f047ac4b5, which was push on Aug. 17th, 2015.
>> I checked that the branch has merged your code.
>> After I boot up the system, I tried the following commands and it shows some 
>> errors.
>> ***
>> My question is
>> ***
>> :
>> 1) Is there any specific BIOS configuration I need to configure?
>> 2) The CMT is not enabled by default. Do I need to issue any command to 
>> enable it?  I didn't find any document about how to enable it, according to 
>> http://xenbits.xen.org/docs/unstable-staging/misc/xl-psr.html. :-(
>> 3) I'm not 100% sure if this machine we purchased supports the CAT. Right 
>> now, it shows "No such device" on the machine.
>> But it may probably because the hypervisor forgot to initialize it?
>> Below is the details of what I tried:
>> # xl psr-hwinfo
>> Cache Monitoring Technology (CMT):
>> Enabled         : 0
>> Cache Allocation Technology (CAT):
>> libxl: error: libxl_psr.c:96:libxl__psr_cat_log_err_msg: CAT is not 
>> supported in this system: No such device
>> Failed to get cat info
>> #xl psr-cmt-attach 0
>> libxl: error: libxl_psr.c:70:libxl__psr_cmt_log_err_msg: CMT is not 
>> supported in this system: No such device
>> Please let me know if you need any further information to confirm if the 
>> machine support the CAT or if it's because there is some issue with the 
>> software layer. :-)
>> Thank you very much for your time and help in this question!
>> Best regards,
>> Meng
>> To get started, use "psr=cat,cmt" on the Xen command line.  Neither are 
>> enabled by default as they can potentially allocate quite a lot of resources 
>> behind the scenes.
> Thank you very much for your suggestion! Yes, after adding the
> psr=cat:1,cmt:1, the CMT works. Command "
> xl psr-hwinfo" shows the total RMID as 31. It means CMT is enabled/working.
> However, the CAT is still not enabled on the socket. It have the same
> error message:
> Cache Allocation Technology (CAT):
> libxl: error: libxl_psr.c:96:libxl__psr_cat_log_err_msg: CAT is not
> enabled on the socket: No such file or directory
> Failed to get cat info
> I looked into the xen/arch/x86/psr.c and found that the function
> cat_cpu_init() just returned without initializing the variable
> "cat_socket_enable".
> Both  !cpu_has(c, X86_FEATURE_CAT) and c->cpuid_level <
> PSR_CPUID_LEVEL_CAT are evaluated as 1 inside the function
> cat_cpu_init().
> OK. I understand that  the cpuid info shows that the CPU does not
> support CAT. However, according to the table at
> http://www.intel.com/content/www/us/en/communications/cache-monitoring-cache-allocation-technologies.html,
>  Intel(R) Xeon(R) CPU E5-2618L v3 should support CAT.
> I'm not sure which part is incorrect: the hardware or the software?
> (Hope Chao could give some insight about this.)
> Best regards,

IIRC, CAT support required a firmware update on the Broadwell hardware
XenServer now has.

See if there is a BIOS update available from your vendor.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.