[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] XEN 4.3.4/4.4.3 Dom0 reboot loop with AMD FX-8350/Gigabyte GA-970A-UD3]

>>> On 25.08.15 at 15:22, <nix@xxxxxxxxxxxxxxxx> wrote:
> Hi. As the subject says. Where from I do start debugging it? My kernel
> boots fine on that machine without XEN.
> I tried the following command line option:
> noreboot=true,iommu=1,no-amd-iommu-perdev-intremap
> OK that stop the loop but how do I get the output so I could see the cause
> of crash/restart? Screen goes just blank with noreboot=true
> I do have AMD-Vi/IOMMU enabled in the BIOS. Tried both F1/F2g BIOS but
> reboot loop still exists.
> Both XEN's are compiled from source via GIT repo.
> My kernel is 3.2.68 with grsec. Disabling grsec made now difference.
> I've attached kern.log.

Since that shows nothing relevant, perhaps the hypervisor log
has something that indicates the reason? Also - are you in fact
reaching the kernel (you saying the screen to just go blank with
"noreboot" suggests you don't)? In which case the question
arises what kernel log it is that you attached - that of a native
kernel boot?

And finally - if you already build from git repo, did you (or can
you) try master instead of 4.3.x / 4.4.x?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.