[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] DomU creation appears to hang when disabling the unix domain socket for oxenstored

First a bit of background: when I started down this path, I was
initially trying to execute xenstored as a stub domain using
origin/master from roughly last week. I managed to get the stub domain
set up and running and convinced dom0 to use it. From there, I could
execute commands like xenstore-ls and xenstore-read to examine the
store. The problems started when I tried to fire up another domU in
addition to the stub domain. That would appear to hang while watching
for the disk backend to transition states to XenbusStateInitWait. I
attached a debugger to xl and traced all of the way down to a write to
/proc/xen/xenbus that occurs during an xs_read from

After asking around on IRC, I received the very helpful suggestion from
andyhhp to try running 'oxenstored --disable-socket' instead of running
xenstored in a stub domain to see if that exhibited similar
behavior. After attempting this, I saw the exact same behavior when
trying to create a domU that I saw when I tried to run xenstored as a
stub domain. I have attached both the xl log and the
xenstored-access.log from that attempt. Also, I am running this on a
Ubuntu 15.04 Dom0 running a 3.19.0-23-generic kernel.

Any thoughts or suggestions on where to go from here? Has anyone run
across this or fixed it in a later version of the upstream kernel?

Attachment: xl-create.log
Description: xl -vvv create dom.cfg

Attachment: xenstored-access.log
Description: oxenstored access log during this run

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.