[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [RFC PATCH V2 5/8] xen/mem_event: Rename mem_event to vm_event

On Thu, Jan 22, 2015 at 3:52 PM, Tim Deegan <tim@xxxxxxx> wrote:
> At 16:17 +0100 on 18 Jan (1421594278), Tamas K Lengyel wrote:
>> The mem_event system has originally been used to deliver memory event
>> related information to helper programs located in a domain. However,
>> the usage of this sub-system have since been expanded to include non-memory
>> related events as well, such as register changes, debugging and 
>> singlestepping.
>> Therefore, renaming the system "vm_event" more accurately describes the 
>> actual
>> usage of the subsystem.
>> In this patch I also clear up the ambiguities that resulted from the 
>> interchanged
>> mem_event and mem_access terminology.
>> Signed-off-by: Tamas K Lengyel <tamas.lengyel@xxxxxxxxxxxx>
> This patch is pretty much unreviewable in that it is both renames and
> edits files, but I'm OK with the general intent.  I see Andrew's
> already suggested some git runes to handle the rename better.

Ack, I'll go with Andrew's route: first introducing the vm_event
system in one patch; second moving everything over to the new naming;
third removing the old mem_event files. This will go somewhat against
the Xen convention of introducing code only when it is immediately
used, but for reviewing purposes IMHO it would be cleaner (or just
merge step and 1&2 into one patch?).


> Cheers,
> Tim.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.