[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] xl: Use proper path for 'do_flr' functionality.



>>> On 24.06.14 at 16:47, <konrad@xxxxxxxxxx> wrote:
> From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
> 
> Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
> introduced an regression where it changed the name from:
> /sys/bus/pci/drivers/pciback/do_flr
> to
> libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> 
> And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
> do /sys/bus/pci/devices/pciback/do_flr. The proper define
> should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.
> 
> Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
> ---
>  tools/libxl/libxl_pci.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/tools/libxl/libxl_pci.c b/tools/libxl/libxl_pci.c
> index 5a7cc9e..d3b35d8 100644
> --- a/tools/libxl/libxl_pci.c
> +++ b/tools/libxl/libxl_pci.c
> @@ -965,7 +965,7 @@ static int libxl__device_pci_reset(libxl__gc *gc, 
> unsigned int domain, unsigned
>      char *reset;
>      int fd, rc;
>  
> -    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> +    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCIBACK_DRIVER);

Don't you then need to drop the literal /pciback part here?

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.