[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH V3 2/5] Config.mk: update OVMF changeset

Il 30/10/2013 15:05, Wei Liu ha scritto:
On Wed, Oct 30, 2013 at 01:57:40PM +0100, Fabio Fantoni wrote:
I also tried with Ubuntu 12.04.3, same pfn error on xl dmesg, same
performance problem (some minutes only for arrive to grub-efi of
dvd) and after other 10-15 minutes without complete the boot I did a
Also for that logs on attachments.

Is QMEU busy-looping?
I probably not understand exactly what you mean, the domU seems
continue to boot apparently but in very slow motion.
Qemu is always active and with low load (on average 5% cpu).

OK. I get it. 5% CPU is OK and expected at this stage.

To get an idea what your guest is doing you probably need to setup
serial console.

Despite windows is bad, it seems that problems persist even in the
test linux except the shutdown with vcpu issue.

The dom0 used have the installation of this:
Except the git branch used (here the hvm-improve.t6) and the qemu:

Oh please don't use staging QEMU. That introduces a new variable which
makes it very hard to identify the genuine problem.

Is based on latest qemu stable (1.6.1).
I tested 1.6 fora long time without see regression and seems more
good than 1.3 on something.
Are there specific reasons to use an older version instead?
If there were it would not be a problem for me to recompile/re-test
with a qemu previous.

If it is working fine for you then it is OK.

But IMHO it is generally better to wait for specific changeset to go
through push gate before conducting your test because that reduces the
variables which might cause regressions.


I also tried another build without change qemu repo and changet but same result. Do you have domUs working on ovmf? If yes what are differences from my test system?

I tried to change also domU parameters:
- removing audio, vdagent and usb redirection it changes nothing.
- switch from stdvga to cirrus vga solves the performance problem, but with Precise it shows always a black screen after start of grub-efi entry, and black screen also with windows 7 installer.

What domU vga you used on your tests?

I'm trying to setup ovmf serial console, but I have no idea on where to start from. Do you have some suggestions?

Thanks for any reply.

If you need more informations and/or tests tell me and I'll do/post them.

About legacy bios support that I mentioned days ago I found this
document about:
Seem that need ovmf change (and probably also on hvmloader) that are
not able to do.

Thank for any reply and sorry for my bad english.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.