[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Xen tools native build on ARMv7

  • To: List Xen Developer <xen-devel@xxxxxxxxxxxxx>
  • From: Vaibhav Bedia <vaibhav.bedia@xxxxxxxxx>
  • Date: Sat, 26 Oct 2013 15:43:56 -0400
  • Delivery-date: Sat, 26 Oct 2013 19:44:31 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>


I am trying to compile the xen tools natively on an OMAP5
board running Debian Wheezy 7.0. Currently the compilation
fails with the following message:

make -C libs install
make[5]: Entering directory `/root/xen/tools/ocaml/libs'
make[6]: Entering directory `/root/xen/tools/ocaml/libs'
make -C mmap install
make[7]: Entering directory `/root/xen/tools/ocaml/libs/mmap'
 MLOPT    xenmmap.cmx
/bin/sh: 1: ocamlopt: not found
make[7]: *** [xenmmap.cmx] Error 127
make[7]: Leaving directory `/root/xen/tools/ocaml/libs/mmap'
make[6]: *** [subdir-install-mmap] Error 2
make[6]: Leaving directory `/root/xen/tools/ocaml/libs'
make[5]: *** [subdirs-install] Error 2
make[5]: Leaving directory `/root/xen/tools/ocaml/libs'
make[4]: *** [subdir-install-libs] Error 2
make[4]: Leaving directory `/root/xen/tools/ocaml'
make[3]: *** [subdirs-install] Error 2
make[3]: Leaving directory `/root/xen/tools/ocaml'
make[2]: *** [subdir-install-ocaml] Error 2
make[2]: Leaving directory `/root/xen/tools'
make[1]: *** [subdirs-install] Error 2
make[1]: Leaving directory `/root/xen/tools'
make: *** [install-tools] Error 2

From what i could gather this is happening due to missing
ocaml-native-compiler for armhf in Debian.

Googling for the solution i came across the page on Xen wiki
which talks about cross-compiling the tools


I initially tried the steps on a machine running Lubuntu 13.04 and after
transferring the dist-tools ended up with the following error message:

root@arm:~/xen# xl
xl: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15' not found
(required by xl)
xl: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15' not found
(required by /usr/local/lib/libxenlight.so.4.3)
xl: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15' not found
(required by /usr/local/lib/libblktapctl.so.1.0)

Next i tried the cross-compilation on a machine running Debian Wheezy 7.2.
However the cross-compiled binaries again gave the GLIBC mismatch error.

How are others getting xen-tools on their ARM platforms? Can someone tell
me how to proceed here?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.