[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.3 development update

Il 13/05/2013 17:08, George Dunlap ha scritto:
On 13/05/13 15:53, Fabio Fantoni wrote:
Il 13/05/2013 12:26, Ian Campbell ha scritto:
On Fri, 2013-05-10 at 15:30 +0100, Fabio Fantoni wrote:
Il 10/05/2013 13:24, Anthony PERARD ha scritto:
On 10/05/13 12:08, Anthony PERARD wrote:
On Fri, May 10, 2013 at 12:00 PM, George Dunlap
<George.Dunlap@xxxxxxxxxxxxx>  wrote:
On Fri, May 10, 2013 at 11:26 AM, George Dunlap
<George.Dunlap@xxxxxxxxxxxxx>  wrote:
* qxl not actually working
    > qxl apparently not enabled during compile by default
    > Appear to be some other bugs even when it is working:
    owner: ? (Anthony was going to take a look)
We need to either fix both of these problems or disable qxl for 4.3
Anthony, you were going to take a look at this; did you make any progress?
Yes, I'm still trying to figure out how to enable qxl in the VM.
And now, I can search why QEMU crash when starting Xorg with qxl.

Hi, thanks for your help.
I'm trying to have qxl full working on xen since end of 2011.
Since half of 2012 is at least working as standard vga.
This means with:
         vga = "qxl"

in your configuration file?
Are you saying that this configuration
For now it works only as standard vga
  If not this then which configuration do you believe works?
With qxl driver enabled on domU's os, qemu crashes
The libxl patch should be correct, also with memory size setting.
I have tried same parameters of libxl qxl patch without xen and are working.
Also without kvm was working even if performance was really bad but at
least qemu did not crash on start with qxl driver.
Based on this test the problem seems to be xen related problem, probably
about hvmloader.
What is the configuration which fails?
See on attachment

Which libxl patch "should be correct"? libxl has lots of patches!
This patch that I refer:

So are you saying that although the libxl patch "should be correct" it
is in fact not sufficient to make qxl work?
The qemu parameters used are correct, for now on xen works only as standard vga but on kvm and qemu-only tests works also with qxl driver.
The difference with xen appares to be only on hvmloader.
I tried to find the exactly problem without result, based on seabios debug I saw that when it detects xen hypervisor, seabios relies on tables passed by hvmloader instead generate them. Is the only effective difference viewed with seabios debug with and without xen.

OK -- so you're saying that qxl actually *does* work, but just in a limited fashion: as long as the guest only access the standard vga interface, then you can connect over spice; but if the guest uses the special qxl interface, then it crashes.

We don't really use qxl, so that wasn't clear at first; we thought that you were saying it didn't work at all.

If it didn't work at all, then there's no point exposing functionality that can't actually work. But since there is new functionality (albeit limited) exposed by the "qxl" option, we should keep it in.

But we do need to make sure to set people's expectations properly -- our release notes will have to advertize "partial qxl support".
I think it is good point to maintain it and advice that is experimental/partial so can be tested/debugged by users. Without that libxl qxl patch users can't test it with simple device_model_args on xl configuration file but they must change libxl code for disable other emulated vga (and also setting proper videoram size).


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.