[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Help to boot domU with customized kernel

  • To: "xen-devel@xxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxx>
  • From: Anand Mundada <anandmundada@xxxxxxxxx>
  • Date: Sat, 27 Apr 2013 08:16:10 -0700 (PDT)
  • Delivery-date: Sat, 27 Apr 2013 15:16:50 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=ymail.com; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:Message-ID:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type; b=E+DsE/7mRsUfnP1pAS2iXPX6azMfiv2AaEYgvQnFi3PnmJoUUonPiYjYe5SuhdUQJCOzugFb5/hEJIXb/tpmvmX6mpFbQUfuZOsEbO/XqgSp0A53HELbFLEyb58eAAfXkOXVc7Puf1sS3dMxP7muz2FFR2nkux+wuxYuzb7tti8=;
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>

Hi All,

I have installed Dom0 and domU following instructions given on Ubuntu Wiki
I want to boot domU with customized kernel. 
My machine don't have hardware support I tried different things but it's not working.

Method 1: 
In guest, I have compiled Para-Virtualized kernel that have created boot images in /boot of domU.
After reboot I am not able to boot and I am getting error as 
Error: Boot loader didn't return any data

Method II:

In dom0, I have compiled Para-Virtualized kernel and I have used domU.cfg file where
kernel= [New compiled vmlinuz]
ramdisk = [New compiled initrd  image]

then I tried to create new VM using 'xm create' command.
Here I am getting following error 

"mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have /sbin/init.
No init found. Try passing init= bootarg. "  

Please let me know to boot domU with new customized kernel?

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.