[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v6 1/2] xen: introduce vcpu_block, use it instead of do_block

>>> On 19.04.13 at 18:33, Keir Fraser <keir.xen@xxxxxxxxx> wrote:
> Three acceptable options:
>  - Leave it as it is
>  - Rename it to vcpu_block_current(void)
>  - Rename to vcpu_block(vcpu *v) but ASSERT(v == current) as a pre-condition
> I like options 1 & 2 best. I'm okay with option 3.

Yet if you go with 3, I'd prefer the parameter to be named "curr"
(some time ago we started to slowly transition the tree towards
that naming in places where the specified vCPU has to be current,
and is being passed as argument to functions just because in
general "current" has slightly higher overhead than argument


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.