[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 1/4] Introduce a new hotplug state: Force eject.
On Tue, 15 May 2012, Anthony PERARD wrote: > This hotplug state will be used to remove a device without the guest > cooperation. > > Signed-off-by: Anthony PERARD <anthony.perard@xxxxxxxxxx> > --- > hw/acpi_piix4.c | 5 +++++ > hw/pci.h | 1 + > 2 files changed, 6 insertions(+), 0 deletions(-) > > diff --git a/hw/acpi_piix4.c b/hw/acpi_piix4.c > index 585da4e..dfd5a9d 100644 > --- a/hw/acpi_piix4.c > +++ b/hw/acpi_piix4.c > @@ -587,6 +587,11 @@ static int piix4_device_hotplug(DeviceState *qdev, > PCIDevice *dev, > return 0; > } > > + if (state == PCI_FORCE_EJECT) { > + acpi_piix_eject_slot(s, 1 << slot); > + return 0; > + } > + > if (state == PCI_HOTPLUG_ENABLED) { > enable_device(s, slot); > } else { > diff --git a/hw/pci.h b/hw/pci.h > index 8d0aa49..3b61e43 100644 > --- a/hw/pci.h > +++ b/hw/pci.h > @@ -273,6 +273,7 @@ typedef enum { > PCI_HOTPLUG_DISABLED, > PCI_HOTPLUG_ENABLED, > PCI_COLDPLUG_ENABLED, > + PCI_FORCE_EJECT, > } PCIHotplugState; Given that it is supposed to be a state rather than an action, it should be called PCI_FORCE_DISABLED or something like that. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |