[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] ATI/AMD VGA passthru report

On Wed 9. of May 2012 19:44:26 you wrote:
> > Hi again!
> > I did first tests with xen-unstable and the #testing kernel.
> > 
> > Windows showed blue screen during boot with xm toolstack.
> > 
> > But I had luck with xl. Windows booted succesfully so I ran the
> > experience index tests:
> > 
> > kernel:       #testing
> > CPU         7,4             7,4
> > RAM         7,4             5,5
> > Aero                7,1             7,1
> > Gr.card     7,1             7,1
> > Disk                7,3             7,5
> So the issue was that 'xm' didn't work but 'xl' did?

In fact it's: and old xen-unstable build (May 2011) with xm toolstack,
#testing and latest xen-unstable with xl toolstack.
No other combinations are working.

> > I tried to run some games as well but the feeling is much worse compared
> > to older configuration. Like lags..
> Do the lags disappear if you pin the vCPUs?

Do you mean for Dom0 or DomU?
I already pin all vCPUs for DomUs. I can try to dedicate one to xen and rest 
to Windows.
But current config (Phenom II X6) was able to run 3 cores for first Windows, 
other 3 cores for second Windows and Dom0 had 2 unpinned cores. All was 
Even 2 cores per instance fro three Windows instances were just fine.
Right now I'm trying just one Windows instance with all cores pinned.

> > Are there some older branches which are supposed to work?
> There is not a specific branch per say. There are some auxillary branches
> with patches that enable this and that. So what might work is
> to use my #linux-next branch and merge both devel/misc and devel/ioperm
> in and see what happens. If I get some time today I will try that and
> stick it as tag.
> > I tried xen-4.1.3-rc1 with #testing kernel but it just freezes after
> > while even with Dom0 running. Only sys-rq worked.
> Oh no!

On no to my english.
It should be: system freezes after while even when only Dom0 is running.
How can I debug this? All I can do is reading sysrq messages but I see no real 
dumps in serial console. Like:
SysRq : Show Regs
SysRq : Show Blocked State
SysRq : Show clockevent devices & pending hrtimers (no others)

> > I have second slightly newer system too so I'll retest that one later.

Sorry, no time yet. I just tried same thing I did on old system and result is 
instant reboot somewhere after NIC detection. Maybe the fs is gone somehow..
I have to switch the serial card to debug that one.
Pavel Mateja

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.