[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Problem with dump-core after restoring VM


Sorry to bother you, but I have some problems with dumping core of HVM
domain after previously restoring it from a given save point. After
starting HVM domain from a scratch (i.e. xm/xl create ..) there is no
problem with dumping core. But when I decide to save VM and then restore
it, dump-core fails afterwards.

dom0: Debian Squeeze
hvm domain: Windows Xp (tried both 32bit and 64bit version)
Xen hypervisor: tried on machine with Xen 4.1 (dom0 kernel 3.0.0) and
also Xen 4.0 (dom0 kernel 2.6.32)

Using xm I got error (it's xmlrpclib.Fault exception in _run_cmd() at
Fault 2: "Failed to dump core: (1, 'Internal error', 'Failed to write
buffer (14 = Bad address)')"

Using new xl toolstack I got similar error:
xc: error: Failed to write buffer (14 = Bad address): Internal error
libxl: error: libxl.c:479:libxl_domain_core_dump core dumping domain 14
to ./dump.2: Bad address
core dump failed (rc=-3)

Doing `xm save -c` without stopping VM doesn't cause problem with
core-dump (well, it would be strange if it does), so it seems problem
exist only after restoring VM.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.