[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] crash e100 amd64 >=4GB RAM

Hello list,

I'm using gentoo Linux with xen 3.4.1 and linux kernel 2.6.30 fine till
now where I need more RAM. I used 2GB and now I want to use 4GB.
But upping eth0 (4-port e100 Quad Port Device by Compaq) crashed the kernel.
I tried xen 4.0.0 with linux kernel 2.6.32, same error.
Using swiotlb=force or swiotlb=128,force or iommu=off did not succeed even.
The board has a tg3 gigabit NIC, too. Upping this device does not crash
the kernel.
It must have something to do with e100 driver.

Can anyone help?

Here is some crash information:
kernel BUG at lib/swiotlb-xen.c:454!
[<ffffffff80481120>] e100_rx_alloc_skb+0x190/0x230
RIP [<ffffffff803c56a6>] swiotlb_sync_single_for_device+0x96/0xe0
Segmentation fault

Thanks for your help,

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.