[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Freeze on boot pv domU 2.6.31 with Xen 4.1

On 05/19/2010 11:55 AM, Eric Chanudet (Intern) wrote:
> I am trying to run a PV domU with netchannel2.
> I used to achieve this with the kernel from xen/stable-2.6.31.x on 
> linux-2.6-pvops repository. It does not work anymore, and does not seem to 
> have any relation with netchannel2 (since I tried to remove it from my 
> .config for testing purpose).
> The kernel basically freezes while booting. No error displayed, neither on 
> dom0 serial output (Xen in debug mode), or kernel one's. It just freezes 
> after :
> [    0.000999] xen_balloon: Initialising balloon driver with page order 0.
> [    0.000999] SCSI subsystem initialized
> [    0.000999] usbcore: registered new interface driver usbfs
> [    0.000999] usbcore: registered new interface driver hub
> [    0.000999] usbcore: registered new device driver usb
> [    0.000999] PCI: System does not support PCI
> [    0.000999] PCI: System does not support PCI

Make sure you have "console=hvc0 earlyprintk=xen ignore_loglevel
initcall_debug" on your guest kernel command line to see if we can get
some idea of where its getting up to.

> I'm using the same kernel, with privileged domain configuration, as dom0 
> (2.6.31) on Xen-4.1 last revision.
> I tried 2.6.32 and 2.6.33 for the pv domU, these ones achieve to boot, but do 
> not support netchannel2.
> Since I just want to have a pv kernel handling netchannel2, can anyone advise 
> me a way ?

You're the first person I know to try nc2 in a pvops kernel, so I'm not
surprised you're encountering difficulties.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.