[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] AMD Phenom II 940: mm/vmalloc.c:110 vmap_page_range_noflush

> Ok, I tried to adjust bridge parameters and found that I can finally get  
> pv_ops dom0 to boot in normal timeframe if I comment out all bridge  
> related statements in /etc/xen/xend-config.sxp.  Before with I  
> had (network-script network-bridge) and also tried (network-script  
> 'network-bridge bridge=br0') but these do not work with

I had this problem when I forgot to have 'CONFIG_BRIDGE' enabled in my
.config, and also CONFIG_TAP (but I think that was only used during
guest startup) but I don't think that is your problem. It could be related to

"init: eucalyptus-network (eth0) main process (1156) killed by TERM signal"

which might have mangled the eth0? Why is it being killed?

> However, there are still errors in the pv_ops dom0 console  
> output so I'm attaching the output so someone could see if they are  
> serious or if there are workarounds to improve things.  I'm seeing  
> things like 'unable to locate IOAPIC for xxx', call trace from  

Don't worry about that. These are used to setup the GSI and there is a
second code path that does that.

> enlighten.c, 'd0 domain attempted wrmsr', 'Detected 1226681.732 MHz  
> processor.'(a 1.2 TeraHz processor??? - the processor is actually a 3.1  
> GHz processor), 'No compatible ACPI _PSS objects found.'.

Interesting. My AMD prototype board shows the same data (or sometimes
even higher number)- completly bogus.
> Plus, why do I see slightly different outputs on the consoles?  Some  
> errors only show on one of the consoles but not the other.

That is b/c the Xen console (all prefixed with XEN) shouldn't by default
be in the Linux domain, unless requested.
.. snip..
> (XEN) Command line: dummy=dummy dom0_mem=1024M  vga=text-80x50  loglvl=all 
> guest_loglvl=all sync_console console_to_rin1

or unless you use console_to_ring at which point all of the output
should be synced together. Except that you have '1' at the end instead
of 'g'.

.. snip..
> GR: now login prompt shows up immediately:

> Ubuntu lucid (development branch) grp-01-23-02 hvc0
> grp-01-23-02 login: 

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.