[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Problems upgrading 3.4 to 4.0? WAS: Xen on vmware

Hmmm... I am having the same problem BUT not on VMware.


I built and installed xen-4.0.0.tar.gz on a xen-3.4 based system (Oracle VM) and got the same problem (xc.xeninfo not implemented). (Yes, I built and installed tools and dom0 (2.6.18-xen) too.)


Then I tried xen-4.0-testing.hg and got the same thing.


I wonder if thereâs some 3.4 residue that is screwing up 4.0 installs?


I hate to reinstall the whole system from scratch, but I can if necessary.


From: eXeC001er [mailto:execooler@xxxxxxxxx]
Sent: Friday, April 23, 2010 9:43 AM
To: Xen-devel
Subject: [Xen-devel] Xen on vmware




I tried to start Xen Dom0 in vmware virtual machine (Debian Squeeze).


xen-tools from xen-unstable.


xen-4.1 (from mercurial xen-unstable) - PASS (kernel, hypervisor, xend)


xen-3.4 (from Debian Squeeze) - FAIL (kernel (PASS), hypervisor (PASS), xend (FAIL))



[2010-04-23 03:01:35 1472] INFO (SrvDaemon:332) Xend Daemon started

[2010-04-23 03:01:35 1472] ERROR (SrvDaemon:349) Exception starting xend ((38, 'Function not implemented'))

Traceback (most recent call last):

  File "usr/lib/python2.5/site-packages/xen/xend/server/SrvDaemon.py", line 335, in run

    xinfo = xc.xeninfo()

Error: (38, 'Function not implemented')

[2010-04-23 03:01:35 1471] INFO (SrvDaemon:220) Xend exited with status 1.



What is the difference?


p.s.: xen-tools from xen-unstable and xen-3.4 works fine on bare-metal



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.