[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] ACPI suspend/resume on Dell Inspirons 1464/1564/1764

  • To: "Jeremy Fitzhardinge" <jeremy@xxxxxxxx>
  • From: "Roger Cruz" <roger.cruz@xxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 4 May 2010 18:06:22 -0500
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 04 May 2010 16:11:14 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: Acrr3HTAqiRKgcpwQ4Kl905V55x/owAAfT49
  • Thread-topic: [Xen-devel] ACPI suspend/resume on Dell Inspirons 1464/1564/1764

It is my understanding that my colleague tried the upstream on a bear metal and it works but when the same patch is applied to our 2.6.32 dom0 xen kernel, it does not.  He believes he issue needs to be addressed in the hypervisor's resume path.  I'm just jumping into this problem right now so I'm coming up to speed.  I wanted to first find out from the community if anyone else had seen a similar issue.  It is a tough problem for us to debug as we don't have any serial port on these Dell machines so we have no indication on how far the resume code has reached.


-----Original Message-----
From: Jeremy Fitzhardinge [mailto:jeremy@xxxxxxxx]
Sent: Tue 5/4/2010 6:52 PM
To: Roger Cruz
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] ACPI suspend/resume on Dell Inspirons 1464/1564/1764

On 05/04/2010 03:25 PM, Roger Cruz wrote:
> I'm about to start debugging why Dell Inspirons running Xen 3.4.2 fail
> to resume after a suspend operation.  A colleague has also found that
> the problem exists on bare-metal Linux
> (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/571422) and an
> upstream patch has been created
> (http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commitdiff;h=29c60ccc1a408371885d79d8f8c081fbcb9b10be).
> I would like to find out if anyone in the Xen community has
> encountered this problem and if a fix is in the works.  Otherwise, I
> will attempt to provide a similar solution to Linux's patch.
> ACPI suspend/resume on Dell Inspirons 1464/1564/1764

I think the Linux fix should work under Xen as well.  Have you tried a
xen/stable-2.6.32.x kernel (assuming the fix is now in mainline Linux).
If not, you should be able to apply it to that kernel and try it out.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.