[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] "xm save" fails on kernel.org domU with Xen 3.4.1

Jeremy Fitzhardinge wrote:
On 10/30/09 14:25, Yasir Assam wrote:
I sent this message to xen-users and it was suggested on that list
that I send it here (no one was able to help me there).

I've installed Xen 3.4.1 from source. Some of my paravirt domUs use
the official XenLinux kernel (2.6.18) and some use the mainline

When I run "xm save" on the kernel.org guests, the "xm save" command
hangs where its run in dom0, and on the domU console I get an error:

PM: Device rtc_cmos failed to suspend: error -22
xen suspend: dpm_suspend_start -22

I'm using kernel version for the domU (I've also tried, which I've built from source (the XenLinux domUs suspend
without a problem).

Is this a bug or am I doing something wrong?

Quite possibly a bug.  Though I haven't seen those particular messages
before, they do seem like the kind of messages that would pop up and
spoil your suspend.
I got some other messages before from bits of of the kernel I didn't need, and I kept switching those bits off until I got the rtc_cmos error (I didn't know how to switch that bit off).
  Could you post a full kernel log of a suspending
I'm not sure what you mean by a full kernel log. Do you mean the output of dmesg? Or /var/log/syslog?
Have you tried migration?
I haven't tried it - I only run Xen on a single host. If it can migrate to itself I can give it a try.

No virus found in this outgoing message.
Checked by AVG - www.avg.com
Version: 8.5.423 / Virus Database: 270.14.39/2468 - Release Date: 10/29/09 
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.