[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [drm:r100_ring_test] *ERROR* radeon: ring test failed

On Tue, Oct 20, 2009 at 12:58:05PM -0400, Konrad Rzeszutek Wilk wrote:
> > > > http://pasik.reaktio.net/xen/pv_ops-dom0-debug/radeondebug/dmesg-
> > > 
> > > Nah. Still has the same problem:
> > > 
> > > [drm:r100_ring_test] *ERROR* radeon: ring test failed 
> > > (sracth(0x15E4)=0xCAFEDEAD)
> > > [drm:r100_cp_init] *ERROR* radeon: cp isn't working (-
> I looked a bit at the code and tried to reproduce this, but found out that 
> the hardware I've is
> a bit too modern for mode-setting to work (no support yet for RS780).
> I looked at the code yesterday and I think I've found the
> the failure. But I don't have yet a test bed for this, so if you
> are willing to be guinea pig, please test this patch (also attached):

I updated the pv_ops dom0 git tree to the latest tree as of
today, and also applied your ttm.patch.

Modesetting works now, and there are no drm/radeon errors.
USB related errors/tracebacks remain though.


-- Pasi

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.