[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] why are deep cstates disabled?

> > My D630 has no HPET... or at least there is no indication
> > in the BIOS menu that there is an HPET.
> I think you do, since cpuidle_disable_deep_cstate() is called from
> handle_rtc_once(), which gets set up as a hook by 
> hpet_broadcast_init(),
> which only gets that far If it has managed to initialise an HPET.
> > I tried setting "hpetbroadcast" and dom0 boot fails.
> Err.. What happens?

Transcribing from the console...

INIT: version 2.86 booting
      Welcome to ....
      Press 'I' to enter ...
Real Time Clock Driver v1.12ac
select() to /dev/rtc to wait for clock tick timed out
Setting clock (utc): xxx [OK]
Starting udev:           [OK]
Loading default keymap (us) [OK]
Setting hostname localhost.localdomain [OK]
Setting up Logical Volume Management.... [DOM0 FREEZES HERE]

I suspect some timeout is being ignored?

The boot continues fine if I do not specify hpetbroadcast.

> > Is there any way to get C3 working on my box or am
> > I out of luck?
> You could try commenting out function disable_pit_irq() and 
> its __initcall()
> invocation. This should cause fallback to pit_broadcast mode. It's a
> completely different non-HPET-related approach that you could try.

I tried this and got the same dom0 boot failure as above
EXCEPT no line beginning with "select() to /dev/rtc..."
(Same failure with and without hpetbroadcast option.)


P.S. This is with tip (c/s 20341) but NOT latest dom0.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.