[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] Xen not getting out of S3

  • To: "Ron Reiter" <ron@xxxxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: "Tian, Kevin" <kevin.tian@xxxxxxxxx>
  • Date: Tue, 12 Aug 2008 09:11:52 +0800
  • Cc:
  • Delivery-date: Mon, 11 Aug 2008 18:12:17 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: Acj7xyZNDyjD+CdvQGWLDEoVpwNk+AAT4wlA
  • Thread-topic: [Xen-devel] Xen not getting out of S3

Did you have serial connected to your box, and any outputs? How do you identify no devices back to work, from screen? If your graphics gets some issue after S3 resume, you may not be able to identify the resume progress... Does 'ping' still work after S3 resume?
Which Xen version in your case?
For Xen case, is there any difference among console, VESA X, ...?
Could you trigger sleep directly by using "echo mem > /sys/power/state"?
If your bios has some option like "VGA repost after S3", you may enable it to see difference.
Also SMP/UP difference can be tried which was once mentioned by somebody (not sure who, but just in my memory. :-)

From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Ron Reiter
Sent: 2008年8月11日 23:30
To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Xen not getting out of S3

After quite a lot of playing with pm-suspend quirks, I've managed to figure out that Xen does not wake up from suspend correctly on my HP Compaq 6510b.

I am running Ubuntu 8.04 with Xen-3.2.1.


I've tried suspending from console, VESA X and accelerated X (Intel Mobile GM965/GL960 Integrated).

When Xen is not running, suspending from X works correctly (There are a few issues such as that the backlight does not turn on when using VESA), while from console it does not (for some strange reason).

When I restore the computer from sleep state with Xen, the fan starts working, but the computer freezes completely and no devices return from sleep (such as wifi).

I've also tried playing with Xen's acpi_sleep boot option (s3_mode, s3_bios) and no combination of the flags works.


I was able to suspend Xen once correctly with the command "pm-suspend" with no arguments, but I am not able to reproduce this.


Does anyone have any idea why this happens?


-- Ron

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.