[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] Issues Related to GCC Compiler

  • To: "Ian Pratt" <Ian.Pratt@xxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: "Huang2, Wei" <Wei.Huang2@xxxxxxx>
  • Date: Fri, 25 May 2007 23:48:18 -0500
  • Delivery-date: Fri, 25 May 2007 21:46:43 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AcefC+l5tpHsLYGDR3alJ4Is2Ukw4QADT0oQAA2P1Zk=
  • Thread-topic: [Xen-devel] Issues Related to GCC Compiler

I just tried different combinations. From domain migration's perspective (using localhost as source and target), gcc 4.0.2 and gcc 4.1.2 do NOT have difference on changset 15034 and 15035. Four combinations have similar results. Basically, the migration can not finish. I saw target guest co-exists with source guest forever (see "xm list" below).
Anyway, these are preliminary results. I will try other change sets and experiments to isolate the root cause. The problem reported by Stefan might be relevant.
~ # xm list
Name                                      ID   Mem VCPUs      State   Time(s)
Domain-0                                   0   500     2     r-----     99.0
ExampleHVMDomain                           6   128     0     -bp---      0.0
migrating-ExampleHVMDomain                 5   128     1     ------     10.1

From: Ian Pratt [mailto:Ian.Pratt@xxxxxxxxxxxx]
Sent: Fri 5/25/2007 5:08 PM
To: Huang2, Wei; xen-devel@xxxxxxxxxxxxxxxxxxx
Cc: ian.pratt@xxxxxxxxxxxx
Subject: RE: [Xen-devel] Issues Related to GCC Compiler

> We have not pinned the changeset which is causing the problem. I
> believe it should be one of the past 60+ changsets because changset
> 15017 worked well with gcc 4.0.2.

My bet would be 15035 -- would be great if you can confirm.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.