[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: user/hypervisor address space solution

On Feb 15, 2006, at 5:23 AM, Keir Fraser wrote:

Should be called get_guest/put_guest/copy_from_guest/copy_to_guest. Better names, and the arch-specific old functions can still keep their old names.

I don't think I understood your full meaning before, but I'm with you now. get/put_user() will still exist on x86 and mean virtual addresses (kernel or user). The new get/put_guest_offset() implementations will be equivalent.

PowerPC will implement get/put_guest_offset(), but will not implement get/put_user() at all. If those latter calls do make their way into common code (after the PPC code has been merged), every PPC build in the regression test suite will fail, so the patch will be flagged as bad and not committed.

This sounds fine to me, other than that bit about confusing the word "user" to mean "virtual" (since it could of course be a kernel address as well).

Hollis Blanchard
IBM Linux Technology Center

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.