[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Xen3 not booting on SIS 740 based system

  • To: xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: Frank Burkhardt <fbo2@xxxxxxx>
  • Date: Wed, 8 Feb 2006 18:03:09 +0100
  • Delivery-date: Thu, 09 Feb 2006 10:06:56 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>


(please CC to me - i'm not subscribed to xen-devel)

I'm not sure, if it's ok to post here. xen-user seems to be the right place
for discussing problems with a running xen but I'm unable to get that far.

Linux (Dom0) when running under Xen can access neither the PCI bus ( 'PCI:
System does not support PCI' ) nor ACPI ( 'kernel BUG at
drivers/acpi/osl.c:507!' ) which eventually makes the kernel not find its
root partition (acpi on) or crash (acpi off).

I tried with and without ACPI enabled (acpi=off as xen-parameter, not as

Some information about my system:
   * Debian Sid
   * AMD Duron based System with SIS 740 Chipset
   * tried:
      * Xen-3.0-TestCD-r3.0-1
      * manually compiled xen 3 unstable dated 02.02.2006 (Kernel 2.6.15)
   * hardware is ok, the problem occures on a different system based on the
     same sis-chipset, too
   * Xen 2.0.6 runs fine
   * Kernel 2.6.15 runs fine without xen

The serially logged output of two boot processes can be downloaded here:
   * with acpi:    http://fbo.no-ip.org/m/sis-xen-acpi.txt
   * without acpi: http://fbo.no-ip.org/m/sis-xen-noacpi.txt

What can I do to either get Xen 3 working on this system or to get an idea,
where to look for the problem? Is there some trick to increase verbosity of
the output? I tried all the make-parameters mentioned in the docs
(verbose=y, ...) but that didn't change anything.


Frank, Xen fan

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.