[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Unmodified Windows etc on XEN 3.0 with Intel/VT or AMD/Pacifica

None of these suggestions are sure fixes, but give these a try, one might work.

vcpus=1 (i don't think vmx supports more than 1 cpu yet)

try different combinations of acpi and apic 0:0, 1:0, 0:1, 1:1

are you sure /dev/sr0 is mountable and has the win2k install cd? I haven't
actually tried windows 2000, only windows xp and windows 2003

Adam Wendt
IPCoast, Inc.

On Mon, 30 Jan 2006 23:11 , Thorolf Godawa <nospam@xxxxxxxxx> sent:

>first thanks a lot for your answers!
>That's what I have in my config now, based on the xmexample.vmx:
>kernel = "/usr/lib/xen/boot/vmxloader"
>memory = 512
>name = "win2k.vmx"
>vif = [ 'type=ioemu, bridge=xenbr0' ]
>disk = [ 'file:/data/xen/images/win2k/win_boot.img,ioemu:hda,w' ]
>That's what I get if I start the VM:
># xm create win2k.vmx
>   -> Using config file "win2k.vmx".
>      VNC= 1
>      vncviewer -listen: Listening on port 11001 (flash port 10901)
>      vncviewer -listen: Command line errors are not reported until a 
>connection comes in.
>Started domain win2k.vmx
>So I'm not able to get a window on my xenU-domain :-(
>I also tried it with stdvga=1 and vnc=0, then a black window opens, 
>shows me some BIOS-information, s.th. about drives but then it stops 
>with a blinking cursor.
>Any help would be nice, thanks a lot!
>BTW: I'm using SuSE Linux 10.1 Beta2 x86-64 on Xeon/VT with Kernel 
>2.6.16_rc1_git3-4 and XEN 3.0_8628-2. Using SLES 10 Beta or SuSE Linux 
>10.0 results in not working onboard ethernet-interfaces.
>Chau y hasta luego,
>Xen-devel mailing list

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.