[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Invalid or unsupported executable format, or is it a reiserfs problem?

On Thu, 2005-02-17 at 16:32, Steven Hand wrote:
> On Thu, 2005-02-17 at 14:56, Steven Hand wrote:
>     > Our newly build xen kernel does not boot. The error message is : Invalid
>     > or unsupported executable format. 
>     > 
>     > I have build xen from the xen-2.0.4 source (make world, make install) on
>     > a debian sarge system. 
>     > I have not changed any of the kernel configurations, I did make an
>     > initrd image. 
>     > The entry in my menu.lst is : 
>     > 
>     > title           Debian GNU/Linux, kernel 2.6.10-xen0 
>     > root            (hd0,0) # I also tried without this line. 
>     > kernel          /boot/xen.gz dom0_mem=64000 
>     > module          /boot/vmlinuz-2.6.10-xen0 root=/dev/hda1 ro 
>     > module          /boot/initrd.img-2.6.10-xen0 # Also tried without this
>     > line 
>     > 
>     > The server's / (/boot) partition is reiserfs. I wonder if this is the
>     > problem? I found messages saying that it doesn't work with reiserfs and
>     > others that say it should work. What is the final answer? 
>     > Looking in the kernel config file: reiserfs is build into the kernel,
>     > not as a module. 
>     What does `file /boot/xen.gz' say? 
> /boot/xen.gz: gzip compressed data, from Unix, max compression
>     What does `cat /boot/xen.gz | gunzip -c | file -` say? 
> /dev/stdin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
> statically linked, stripped

Ok, that looks good. 

>     > As a side note: the standard debian 2.6.8-2 kernel works perfectly. 

Hmm: what is the menu.lst you use for that? In particular, is the
kernel you boot in the same directory as xen.gz? 

=== original debian entry in menu.lst (grub-update)===
title           Debian GNU/Linux, kernel 2.6.8-2-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.8-2-386 root=/dev/hda1 ro
initrd          /boot/initrd.img-2.6.8-2-386
=== end ===

Yes, xen.gz is in the same directory (/boot).
Nothing about -o notail inhere.

What's the overall makeup of your partitions + filesystems in the
machine? I'm guessing /dev/hda1 is { /boot, reiserfs } -- what 
about the rest of the system? 
/dev/hda1  /  (reiserfs 700MB, no separate partition for /boot)
/dev/hda2  swap  (120 MB)
/dev/hda5  /home (reiserfs 1,3GB)
> Thinking ahead, suppose reiserfs has to be dropped, will it suffice to
> just convert the /boot partition to ext3 or does the entire / partition
> need to be converted?

Well ideally it should all "just work" even with reiserfs as /boot. 

How did you get xen.gz onto /boot? Did you copy it from an ext2/3 
partition? There seems to be something weird about reiserfs and 
grub involving the "-notail" mount option... 
xen-2.0.4.tgz was copied and unfolded in my /home/<user> directory
cd xen-2.0
make world
wait, wait very long (200Mhz, testing machine - proof of concept setup)
make install   # this copied everything in place automatically: xen.gz and vmlinuz-2.6.10-xen0 and the other stuff to /boot, /etc/init.d /lib/modules, ...
mkinitrd -o /boot/initrd.img-2.6.10-xen0 2.6.10-xen0
change menu.lst in /boot/grub, add the xen stuff as described earlier
reboot -> oops: not working ... damn

Would an attache serial console provide more information that is usefull to you? If yes, I go buy a cable.


Filip Sergeys


SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list
* System Engineer, Verzekeringen NV *
* www.verzekeringen.be              *
* Oostkaai 23 B-2170 Merksem        *
* 03/6416673 - 0477/340942          *



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.