[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] XEN problems when using large # of NICs in domain U

  • To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
  • From: Eric Tessler <maiden1134@xxxxxxxxx>
  • Date: Fri, 11 Feb 2005 17:19:23 -0800 (PST)
  • Comment: DomainKeys? See http://antispam.yahoo.com/domainkeys
  • Delivery-date: Sat, 12 Feb 2005 01:23:43 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; b=fFwPVXuPZZXy3LVgItmwRTDU2/ztIer+hPyalNPsQetgTecXgnoS2DIQWciaSuy1gHlayZLuM4aDys8qqytdbfLpNFmuNZv/v3/MOaWONWHBn2dxOwOL0dNOYGBfYXiIAI1dV627ibqn79UyE3IglpWtGLwglKwiNHTzM0clgJ0= ;
  • List-id: List for Xen developers <xen-devel.lists.sourceforge.net>

I am trying to test XEN with a large # of NICs in domain U.  I configured a single domain U to have 128 NICs (by simply setting the # of NICs to 128 in the domain U configuration file). When I try to create the domain using "xm create domainU -c", the domain starts to boot but then hangs when it reaches the stage of initializing the virtual NICs (xen_net: Initialising virtual ethernet driver).  After about 30 seconds, the machine reboots on its own.
If I set the # of NICs to 512, domain U does not boot and instead I get the following error message from xm: "Error: Callback timed out".  The machine does not reboot in this case.
The magic number appears to be 122 - I can set the # of NICs to 122 and domain U boots with no problems.  If I go to 123, it hangs and reboots my machine.  I can also configure 2 domain U's each with 61 NICs and that works fine.  However if I increase one of them to 62 that domain fails to start and my machine reboots (so the total is 123).  This also implies that the maximum # of domain U's possible on one machine is 122.
This does not appear to be a problem with the bridge - I did a little debugging and it turns out that in all cases XEN sucessfully instantiates the back-end network drivers and adds them to the bridge (all VIFx.y interfaces are visable and registered with the bridge).  This could be a problem with the front-end network drivers. I don't see any failure debug ouput in any of the XEN logs.
I tried all tests on 3 different physical machines with different amounts of memory.  The domain U's were configured with different amounts of memory (from 64MB to 512MB).  This does not appear to be a memory issue.
Has anyone else tried this or have any other information on why this may be occuring?

Do you Yahoo!?
Yahoo! Search presents - Jib Jab's 'Second Term'



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.