[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] error: (XEN) Not enough memory for DOM0 memory reservation.

Dear list,

I'm trying to get Xen working on a P3-600E with 320 MB RAM. (256+64)

It has suse linux 9.1 installed on it, and I tried to get xen running with
both the binary download from the xen pages and the suse xen packages
mentioned on this list some days ago.

Both 'install packages/kernels' lead to the same error:

(XEN) Not enough memory for DOM0 memory reservation

Whereafter a poweroff/poweron is the only way ouy. (Machine doesn't have a
reset button, keyboard ctrl-alt-del does not respond)

The grub entries are:
title Xen 2.0 / XenLinux 2.6.9
        kernel (hd0,1)/boot/xen.gz dom0_mem=131072 console=vga
        module (hd0,1)/boot/vmlinuz-2.6.9-xen0 root=/dev/hda2 ro console=tty0

title Xen2
        kernel (hd0,1)/boot/xen.gz dom0_mem=65536
        module (hd0,1)/boot/vmlinuz-2.6.8-24.8-xen root=/dev/hda2 vga=0x314 
splash=silent desktop resume=/dev/hda1 showopts
        module (hd0,1)/boot/initrd-2.6.8-24.8-xen.gz

Lowering the dom0_mem anything between 8192 to 13300 works, but then the
kernel reboots during the boot process (for low values) and for higher
values the boot script processes get killed by oom_kill, who eventually
killes init too, kernel panics->reboot.  Setting dom0_mem to 13313 or
anything bigger doesn't work, produces the error "Not enough memory for
DOM0 memory reservation".

What happens between 13300 and 13313 is untested, I think it has been
narrowed down sufficiently.

How can I solve this ? And/or what could I be doing wrong?

Thanks in advance,

Floris Martens

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.