[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xenU wont boot, cannot open root device

> Maurice Meeden wrote:
> > I am trying to replace uml with xen, but I cant get the unpreviliged
> Domains
> > booting..
> > Ive tested a cuple of filesystems in a file (ext3 or xfs formatted) and
> Ive also
> > tried the ttylinux-xen image. But I always get this error:
> > VFS: Cannot open root device "hda1" or unknown-block(3,1)
> > Please append a correct "root=" boot option
> > Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(3,1)
> > Ive no ideas what else I could try, can somebody give me an hint please?
> Are you using the prebuilt unprivileged-domain kernel image? If so, the 
> one in 2.0.1 at least (maybe others, not sure) has devfs support 
> enabled. This breaks things. I suggest you rebuild your domU kernel 
> _without_ devfs support, and it should work correctly. I had this same 
> problem when I began playing with Xen, but after rebuilding the kernel 
> as I mentioned, it all worked correctly.

Thank you very much, it works now.
Ive thought its enough to add devfs=nomount to the kernel parameters, but
you are right, CONFIG_DEVFS_FS must be unset.

Merry Xmas, Maurice

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.