[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] xenU wont boot, cannot open root device

  • To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
  • From: Maurice Meeden <tux@xxxxxxxx>
  • Date: Wed, 22 Dec 2004 17:11:31 +0000 (UTC)
  • Delivery-date: Thu, 23 Dec 2004 06:27:18 +0000
  • List-id: List for Xen developers <xen-devel.lists.sourceforge.net>


I am trying to replace uml with xen, but I cant get the unpreviliged Domains
Ive tested a cuple of filesystems in a file (ext3 or xfs formatted) and Ive also
tried the ttylinux-xen image. But I always get this error:
VFS: Cannot open root device "hda1" or unknown-block(3,1)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,1)

The config is the same as in the example:
kernel = "/uml/linux-2.6.9-xenU"
memory = 64
name = "ttylinux"
nics = 1
disk = [ 'file:/uml/ttylinux-xen,hda1,w' ]
root = "/dev/hda1 ro"

Ive also tried sda1 instead of hda1, or hexadecimal.

Ans I also tested different versions, xen 2.0.1 and 2.0-testing, with a stock
Linux kernel, and the prepatched Gentoo-dev-2.6.9 Version. I compiled with and
without 4k stacks, but always the same :-(

Ive no ideas what else I could try, can somebody give me an hint please?

Greetings Maurice

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.