[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: Xen packages for SUSE Linux

In reply to  Kurt Garloff's announcement of experimental Xen
packages for SuSE 9.2

Sorry for 'top posting' but I have only just joined the list
and I don't have the reference for the original message.

I tried the packages, both as a domain0 and domainU but I ran
into problems in both cases. I think they may have misbehaved
in different ways in each case. I will describe the domainU
case in another post to keep the length down.

I was installing on a laptop computer (Sony PCG-GR114SK) that
already had SuSE 9.2 installed on it (via an upgrade from an
earlier 9.1 system). It might have some customised bits in
the startup scripts. It boots up fine with the SuSE default
(i586) kernel. No serial port unfortunately :(

With hindsight this was perhaps not the best test machine to
choose. I can try again with another machine.

I am using lvm to carve up the disk. I have the following
logical volumes.

    (this is for a UML instance running in a chroot jail)
    (this contains temporary files)
    (another linux installation that I am using as an alternative
     domain0 for testing purposes)

All the logical volumes are formatted ext3

Here are the lines I added to my grub menu to start up the domain0
SuSE kernel:

title Xen SuSE 9.2
    kernel (hd0,0)/xen.gz dom0_mem=256000 console=vga
    module (hd0,0)/vmlinuz-2.6.8-24.6-xen root=/dev/system/root
splash=silent i8042.noaux=1 desktop showopts console=tty0
    module (hd0,0)/initrd-2.6.8-24.6-xen

If I use a loopback device to mount the initrd, I can see the
following modules:

rjd:/tmp/mnt0/lib # cd ..
rjd:/tmp/mnt0 # find ./lib/modules/2.6.8-24.6-xen/kernel/
rjd:/tmp/mnt0 #

As I said earlier, I can get a bash prompt if I pass init=/bin/bash
on the kernel command line.

I haven't reproduced the dmesg output. I can do this if you request
it, but I think I may have to transcribe it by hand onto another
fully functioning machine. However did spot this in the boot traffic:

  Loading kernel/drivers/ide/pci/piix.ko
  module piix unsupported by SuSE/Novell, tainting kernel.

I am at the bash prompt. init has not been run yet. If I try to
remount the root filesystem as 'rw' and touch some file, the machine
locks up on the touch command.

Typing ^C does help.

The SysRq key is still working e.g. you can type Alt-SysRq-P to show
a backtrace.

The LED for the harddisk is permanently lit. I can't hear/feel any
obvious disk seek noises.

I don't think the CPU is running many cycles because the machine stays
cool and the fan doesn't come on. (The fan works even if you are not
using acpi). Typing Alt-SysRq-P seems to indicate that the machine is
in the idle loop. hand transcribed from the screen:

  PID:0 comm: swapper
  EIP:061:[<c010eddd> CPU:0
  EIP: is at xen_idle+0c6d/0x140
    EFLAGS: 00201246 tainted: G U (2.6.8-24.6-xen)
  EAX:00000006 EBX:00000001 ECX:799fea00 EDX 76a4f980
  ESI:00000001 EDI:c03ee9c0 EBP:00000000 DS:0069 ES:0069
    [<c010eecf>] cpu_idle+0x1f/0x30
    [<c03ca74f>] start_kernel+0x17f/0x1d0
    [<c03ca330>] unknown_bootoption+0x0/0x170

Ocassionally when typing Alt-SysRq-P, you see a longer backtrace.
Guessing from the function names, it looks like it is running an
ide interrupt service routine

  PID:0 comm: swapper
  EIP:061:[<c0283bb3> CPU:0
  EIP: is at ide_inb+0x3/0x10
    EFLAGS: 00201206 tainted: G U (2.6.8-24.6-xen)
  EAX:000001d0 EBX:00000000 ECX:00000000 EDX:000001f7
  ESI:0000a6cf EDI:c043bbac EBP:c043bb00 DS:0069 ES:0069
    [<c028451c>] ide_wait_stat+0xfc/0x190
    [<c028d4cc>] __ide_d_rw_disk+0x20c/0x5c0
    [<c010be44>] hanfle_IRQ_event+0x44/0x90
     ----------  start_request
     ----------  ide_do_request
     ----------  ide_intr
     ----------  multiwrite_intr
     ----------  handle_IRQ_event
     ----------  do_IRQ
     ----------  evtchn_do_upcall
     ----------  hypervisor_callback
     ----------  xen_idle
     ----------  cpu_idle
     ----------  start_kernel

I tried Alt-SysRq-8 to try to get more messages, but there is only

I had to have powered off the machine by holding
the power button down for four seconds to get the machine to reboot.

Letting the machine try to boot normally into runlevel 3, the boot
appears to proceed normally for a while then hang. It didn't always
hang at the same point during boot. It never got as far as presenting
a login prompt.

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. http://productguide.itmanagersjournal.com/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.