[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] can't mount root... devfs???

> I'm now recompiling both xen0 and xenU with devfs not compiled in (I had 
> tried booting xenU with devfs=nomount and it didn't make a difference).
> One thing I did just notice is now that the xenU config is fixed for SCSI 
> (make menuconfig would crash if you tried to access SCSI), I can actually go 
> in there and enable or disable scsi in the kernel. I assume that even though 
> xen0 is using the scsi device directly, and that i'm exporting /dev/sda7 to 
> xenU, xenU shouldn't need any scsi block devices at all, is that correct? 
> SCSI was enabled, i'm now trying it with SCSI not selected at all.
> thanks
> James

Correct --- you don't need low-level device drivers in xenU. If we
were prepared to modify the drivers/scsi/config, we'd remove the
low-level driver options when configuring a non-privileged kernel.

 -- Keir

This SF.Net email sponsored by Black Hat Briefings & Training.
Attend Black Hat Briefings & Training, Las Vegas July 24-29 - 
digital self defense, top technical experts, no vendor pitches, 
unmatched networking opportunities. Visit www.blackhat.com
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.