This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [PATCH V7 2/7] libxl: Add get/set_default_namespace in l

To: Ian Campbell <Ian.Campbell@xxxxxxxxxxxxx>
Subject: [Xen-devel] Re: [PATCH V7 2/7] libxl: Add get/set_default_namespace in libxltypes.py.
From: Anthony PERARD <anthony.perard@xxxxxxxxxx>
Date: Thu, 21 Jul 2011 13:02:02 +0100
Cc: Xen Devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Stefano Stabellini <Stefano.Stabellini@xxxxxxxxxxxxx>
Delivery-date: Thu, 21 Jul 2011 05:06:09 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1311234980.32010.25.camel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <1311197072-16003-1-git-send-email-anthony.perard@xxxxxxxxxx> <1311197072-16003-3-git-send-email-anthony.perard@xxxxxxxxxx> <1311234980.32010.25.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Alpine 2.00 (DEB 1167 2008-08-23)
On Thu, 21 Jul 2011, Ian Campbell wrote:

> On Wed, 2011-07-20 at 22:24 +0100, Anthony PERARD wrote:
> > Signed-off-by: Anthony PERARD <anthony.perard@xxxxxxxxxx>
> I'm not sure if it matters but default_namespace should possibly be
> private to the module (__ at the start)? Perhaps get_default_namesspace
> too, probably neither .idl files nor gen*.py should ever need to query
> this, they should use the info in specific types.

Ok, I will change names but use only one '_' for "private"

> If I were prone to bikeshedding I'd suggest that "set_default_namespace"
> could be just "namespace" since it would read nicer in the .idl files.

:), I'll change that too.

> In any case that's all nit picking so:
> Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx>


Anthony PERARD

Xen-devel mailing list