On 15 Feb 2006, at 10:48, Hollis Blanchard wrote:
I will be busy for a week or so, but I will try to come up with a patch
that converts x86 and ia64 and all common code to the proposed API:
get_user_offset(val, base, offset)
put_user_offset(val, base, offset)
get_user_array(val, array, index)
put_user_array(val, array, index)
copy_to_user(to, from, len)
copy_from_user(to, from, len)
... plus __ variants of all of these, with identical arguments
... plus arch-specific get/put_user for e.g. xen/arch/x86/domain.c,
since some of those usages don't seem to fit above.
If you don't like the API, please speak up now.
Should be called get_guest/put_guest/copy_from_guest/copy_to_guest.
Better names, and the arch-specific old functions can still keep their
What's the difference between foo_offset() and foo_array()?
Xen-devel mailing list