This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-API] Re: XAPI on Debian - creating and starting a debian squeeze VM

To: Mike McClurg <mike.mcclurg@xxxxxxxxxx>
Subject: [Xen-API] Re: XAPI on Debian - creating and starting a debian squeeze VM
From: Sébastien Riccio <sr@xxxxxxxxxxxxxxx>
Date: Mon, 22 Aug 2011 22:14:57 +0200
Cc: Jonathan Ludlam <Jonathan.Ludlam@xxxxxxxxxxxxx>, "xen-api@xxxxxxxxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Mon, 22 Aug 2011 13:15:11 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4E52B644.1030601@xxxxxxxxxx>
List-help: <mailto:xen-api-request@lists.xensource.com?subject=help>
List-id: Discussion of API issues surrounding Xen <xen-api.lists.xensource.com>
List-post: <mailto:xen-api@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-api>, <mailto:xen-api-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-api>, <mailto:xen-api-request@lists.xensource.com?subject=unsubscribe>
References: <4E52B595.1080200@xxxxxxxxxxxxxxx> <4E52B644.1030601@xxxxxxxxxx>
Sender: xen-api-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20110812 Thunderbird/6.0
On 22.08.2011 22:04, Mike McClurg wrote:
On 08/22/2011 09:01 PM, Sébastien Riccio wrote:

I'm currently trying to boot a vm i created from a template with the
citrix xencenter manager.
The provisioning occured without any problem but the VM does not starts
and throw this

22.08.2011 21:56:39 Error: Starting VM 'Debian Squeeze 6.0 (32-bit) (1)'
- Internal error: Unix.Unix_error(20, "access", "/usr/bin/eliloader")

Maybe this is excepted at this point of the kronos project ?

Yeah, that's the problem I mentioned in my last email. I've attached the eliloader script. Put it in /usr/bin, cross your fingers and give it a try again.


here are the results:

root@xen-blade13:/usr/bin# ./eliloader
./eliloader:41: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Traceback (most recent call last):
  File "./eliloader", line 84, in <module>
mapfiles = [ f for f in os.listdir(guest_installer_dir) if f.endswith('.map') ] OSError: [Errno 2] No such file or directory: '/opt/xensource/packages/files/guest-installer'

I guess these are the paths to the xcp on centos and that I could change them but
the files doesn't exists on the system.

root@xen-blade13:/usr/bin# updatedb
root@xen-blade13:/usr/bin# locate guest-installer

root@xen-blade13:/usr/bin# grep xensource eliloader
guest_installer_dir = "/opt/xensource/packages/files/guest-installer"

seems quite trivial if I can put my hands on the guest-installer files :)


xen-api mailing list